Failed to load the requested file :(
  • PollyPolly Mai 2012
    Hallo ihr Lieben,

    Ich brauche DRINGEND eure Hilfe. Ich arbeite schon seid tagen an diesem File. Und hatt es immer offen auf meinem Computer. Und auch immer zwischengespeichert und jetzt sagt er mir das er das File nicht öffnen kann :( Er sagt "Failed to load the requested file". Das ist echt ne Menge Arbeit und ich kanns nicht glauben das es weg ist :-(. Bitte helft mir. Auch alle Sicherheitskopien die Inkscape automatisch gemacht haben lassen sich nicht mehr öffnen. Aaaaahhhhhh ....
  • fZapfZap Mai 2012
    Welches Betriebsystem, welche Inkscape-Version? Welches Format hast Du gespeichert? Kannst Du die Datei mit inkscape von der Kommandozeile aus öffnen und zwar mit

    # inkscape --g-fatal-warnings  problemdatei.svg bzw
    # %PROGRAMFILES%\Inkscape\inkscape.exe --g-fatal-warnings %HOMEPATH%\problemdatei.svg (unter Windows, wobei %PROGRAMFILES% = C:\Program Files\, %HOMEPATH% = C:\Users\DeinBenutzername)

    Vielleicht auch einmal die SVG-Datei auf Wohlgeformheit validieren: 
    http://www.xmlvalidation.com/documentation.html?L=0
  • PollyPolly Mai 2012
    Ok sorry das sollte ich natürlich dazusagen:

    Also Betriebssystem: OS X 10.7.3
    Inkscape Version: 0.48
    Ich hab es als Inkscape svg gespeichert. Ich glaube das problem liegt an der Datei die ich mit Inkscape geöffnet habe. Das war ein PDF das von AutoCad erstellt wurde. Und das hat auch irgendwie sehr komische gruppierungen... Ich glaube das war der Fehler. Hab nämlich gesehen wenn ich die grupierungen vorher alle aufhebe dann kann ich das file danach auch wieder öffnen. Aber ich hatte ja leider schon erheblich viel Arbeit in das File gesteckt das jetzt nicht mehr zu öffnen ist.

    Ich weigere mich aber das aufzugeben. Also ich hab es mal aus der Kommandozeile gestartet und bekomme diese Fehler:


    Warning: AppleCollationOrder setting not found, using AppleLocale.
    Setting Language: .UTF-8

    (process:2113): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
    /Users/Nora/.inkscape-etc/gtkrc:56: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    /Users/Nora/.inkscape-etc/gtkrc:57: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
    /Users/Nora/.inkscape-etc/gtkrc:58: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
    Leve_ 2.svg:14693: parser error : Excessive depth in document: 256 use XML_PARSE_HUGE option
                                       id="g9784"><path
                                                  ^
    Leve_ 2.svg:14693: parser error : Extra content at the end of the document
                                       id="g9784"><path
                                                  ^

    ** CRITICAL **: Inkscape::XML::Document* sp_repr_read_file(const gchar*, const gchar*): assertion `Inkscape::IO::file_test( filename, G_FILE_TEST_EXISTS )' failed
    aborting...

    Emergency save activated!
    Emergency save completed. Inkscape will close now.
    If you can reproduce this crash, please file a bug at www.inkscape.org
    with a detailed description of the steps leading to the crash, so we can fix it.
    Abort trap: 6


    Kann man da noch was machen? Der XML check sieht gut aus... das werd ich mal versuchen. Vielen Dank!

    lg
    Nora


  • Palatin Mai 2012

    Also ich kenne mich nicht genau aus mit der Sache, aber solange die Datei selbst nich korrumpiert ist hast Du gute Chancen diese irgendwie wieder zu reparieren. 

    SVG-Dateien kann man auch mit einem Texteditor öffnen, da kannst Du mal nach  id="g9784" suchen und schauen ob an diesem Pfadeintrag etwas ungewöhnlich ist - dass ist ja der bei dem Inkscape einen Error meldet.

    PS: und es wäre cool wenn Du der Bitte folgst und dazu wirklich einen Bugreport machst, damit Inkscape sich verbessern kann.

  • fZapfZap Mai 2012
    Im Grunde genommen steht es schon in den Fehlermeldungen der Konsole: Die Datei hat wahrscheinlich eine extreme Verschachtelung von Gruppen ("Excessive depth in document"). Ich kenne das Problem beim Öffnen von pdf-Dokumenten aus anderen Anwendungen, bei Dir AutoCAD. Eine gute Lösung dazu, die Verschachtelung zu lösen, kenne ich leider nicht. Eventuell kann man es händisch machen (Gruppierung auflösen), sobald man die pdf-Datei in Inkscape geöffnet hat, aber das ist natürlich eine stupide Arbeit, vor allem wenn die Gruppen 100-fach verschachtelt sind. Ich schaue noch mal, ob es eine Werkzeug dafür gibt, z.B. einen svg-Optimierer.

    Die maximale Gruppenverschachtelung beträgt derzeit etwa 256, Hinweis siehe: https://bugs.launchpad.net/inkscape/+bug/297070 Das ist der maximale Wert, den der Parser gerade noch verträgt.

  • vaddivaddi Mai 2012
    Bügele Fehler in svg einfach mit nem Text editor manuell aus (ist ja auch nur TEXT/XML). Immer wenn mir ein Kunde mit Corel erstellte SVG Dateien zukommen lässt muss ich erst CorelFormatMüll da wieder raus nehmen, damit ich die Datei dann mit Inkscape öffnen kann.

    Ich löse das Problem mit den Verschachtelungen bei Komplexen SVG Dateien immer so, das ich mir zwischen Bilder (png) erstelle und diese dann in einem neuen Inkscapefenster weiter verwende. Die Verschiedenen Versionen behalte ich für Nacharbeiten immer noch als SVG Datei. Hab zwar so mehr Dateien, aber Inkscape geht auch nicht so schnell in die Knie ;-)

    Lösung für dich ist die Vorletzte Zeile aus dem Log:
    Leve_ 2.svg:14693: parser error : Excessive depth in document: 256 use XML_PARSE_HUGE option id="g9784"><path

    Du kannst dir inkscape selbst kompelieren mit der erweiterung XML_PARSE_HUGE

Hey Fremder!

Sieht so aus als wenn du neu hier bist. Wenn du mitmachen willst, drücke einen dieser Buttons!

In dieser Diskussion