Schwarzer Balcken in Zoomstufe bei Farbverlauf Inkscape
  • Meho Juni 2016
    Hallo Leute,

    ich habe einen kleinen Bug mit dem ich nicht umzugehen weis.
    Googeln hat mich leider nicht weiter gebracht, daher versuche ich es bei euch einmal.

    Wenn ich in einem aktuellen Projeckt von mir rein und raus zoome, erscheinen auf einmal große, schwarze Balcken im Bild. Diese Balcken sehe ich aber nur in bestimten Zoomstufen. Wie ich nun endlich herausgefunden habe werden diese von Farbverläufen erzeugt die ich zu klein skaliere. Also ein Viereck, in dem Viereck ein Farbverlauf von oben nach unten. Das Viereck skalier ich ganz schmal um es als Trennlinie zu nutzen. Wenn ich nun in meinem Bild raus und rein zoome habe ich einen dicken schwarzen Balcken.

    http://postimg.org/image/6s6pdmnyj/

    Kennt jemand das Problem?
    Was kann ich dagegen tun?
    Danke schonmal für eure Hilfe!

    Gruß Meho
  • Ich kenne dieses Problem nicht (da fehlen aber auch noch Angaben über Versionsnummer und OS) - aber Du könntest es ja mal mit einer Linie anstand eines schmalen Rechtecks probieren.

    Gruß
    Frank
  • Meho Juni 2016
    Hallo Frank,

    danke für die Antwort! Das Problem tritt auf bei:
    - Laptop    Windows XP                  Inkscape 0.9r13725
    - Desktop Kubuntu 15.10(Linux)       Inkscape x.xxxxxx
    Den Kubuntu PC hab ich nicht zur Hand und kann die Version nicht ermitteln, sorry!

    Das Problem tritt NICHT auf:
    - Laptop Mint Rebecca (Linux)                Inkscape 0.48.4r9939


    Mit der Konstellation kann man eine Hardware bzw. Treiberproblem mit der Graka ausschließen, da es auf zwei unterschiedlichen Computern mit zwei unterschiedliche Betriebssystemen vor kommt. Leider kann ich die Inkscape Version auf dem Kubuntu System nicht ermitteln.
    Ich dachte der Fehler sei etwas bekannter, da er bei mir schon in mehreren Dateien vor kam.

    Gruß Meho
  • Moini Juni 2016
    Das Problem hatte ich auch noch nie. Kannst Du die Datei(en) mal irgendwo hochladen und eine Anweisung schreiben, was genau man machen muss, um darin die Balken zu sehen?
  • Meho Juni 2016
    Hallo Moini,

    Ich hab die Datei unter folgenden Link hoch geladen.
    Eigentlich musst du die Pfeile nur anklicken und verschieben. Ich hab alle Ebenen die benötigt werden aktiviert.
    Ansonsten mal alle ebenen Aktivieren und probieren es ist nichts wichtiges sondern nur Hobby und kein Geheimnis.

    Danke für euer nachhaltiges Interesse an meinem Problem!
    Grüße Meho 
  • Moini Juni 2016
    Bei mir passiert dabei nichts Außergewöhnliches, weder beim Zoomen, noch beim Pfeile-Verschieben. Kannst Du noch einen Screenshot vom Balken machen, damit wir wissen, wo der auftauchen soll?
  • Meho Juni 2016
    Hallo Moini,

    es tut mir sehr leid, aber meine Infos in meinem letzten Kommentar waren falsch. Ich habe meine beiden aktiven beiträge im Forum verwechselt! SORRY! ^:)^
    Nochmal Richtig:
    Ein Screenshot mit Balcken:
    Screenshot
    Und die Datei bei der der Screenshot aufgenommen wurde:
    Link

    Ich denke aber nicht, dass es an der Datei liegt, sondern eher an der Incskapeversion. Wenn ich die selbe Datei auf dem selben Computer, nur in unterschiedlichen Betriebssystemen, öffne. Dann tritt das Problem einmal auf und einmal nicht.

    Die Balcken erscheinen mei den Unterstrichen unter den Texten, aber auch nur wenn ich die "Unterstreichungslinien" sehr schmal mache. Die "Unterstreichungslinien" haben Verläufe, ich vermute, dass die Verläufe in einem so schmale Bereich zu Fehlern führen.

    Gruß Meho
  • Moini Juni 2016
    :-) - das erklärt so einiges.

    Bei mir gibt es auch schwarze Balken. In den Fehlerberichten konnte ich so etwas nicht finden (was nicht heißt, dass das Problem nicht vielleicht doch schon bekannt ist), und so habe ich eben grade einen Fehlerbericht losgeschickt. Angehängt habe ich dort eine bereinigte Datei, die nur noch 2 rechteckige Pfade mit den Gradienten enthält.

    Was dabei rauskommt, kannst Du hier verfolgen, Meho:
    https://bugs.launchpad.net/inkscape/+bug/1594988
  • Moini Juni 2016
    Für Deine Datei probier doch mal aus, ob es mit Konturen (statt gefüllten Rechtecken einfach nur ein waagerechter Strich) mit einem Gradienten besser klappt. Bei mir scheint es zu gehen.
  • Moini Juni 2016
    Meho, erinnerst Du Dich, mit welcher Inkscape-Version Du die Datei mit diesen Gradienten erstellt hast?

    Im Bugtracker würden sie das gerne wissen :)
  • Meho Juni 2016
    Hallo Moini,

    leider nicht, aber ich kann eine Annäherung versuchen!
    Also ich hatte die Version aus dem Kubuntu-Repository installiert. bei der Kubuntuversion 15.10
    wäre das das Paket "inkscape (0.91-5unbuntu2)".  Das ist die wahrscheinlichste Version!
    Wenn ich die Datei aber aus einem vorhergehenden Projekt weiter entwickelt habe. Was bei mir schon mal vorkommt, da ich alte Projekt gerne als Vorlage nehme. Dann wird es wohl eher die Paket-Version inkscape (0.48.4-3ubuntu2).

    ACHTUNG:
    Das sind die Paketversionen ich weiss nicht, ob diese gleich bedeutend zu den Inkscapeversionen sind!

    Ich hoffe das hilft weiter!
    Du kannst mir auch gerne den Link zum Bugtracker geben und ich rede selbst mit den Entwicklern.

    Gruß Meho
  • Moini Juni 2016
    Danke, Meho :) Der Link ist dieser (s. a. weiter oben ;-) ):

    https://bugs.launchpad.net/bugs/1594988

Hey Fremder!

Sieht so aus als wenn du neu hier bist. Wenn du mitmachen willst, drücke einen dieser Buttons!

In dieser Diskussion