Zeichnung plötzlich unsichtbar
  • DrachenbauerDrachenbauer März 2017
    Hallo

    Ich habe mit bezier-Kurven gezeichnet und plötzlich ist alles Unsichtbar geworden, was ich bisher in diesem Dokument gezeichnet habe...
    Durch alles auswählen und farben verändern wird es komischer weise auch nicht wieder Sichtwar...
    Die Deckkraft der Ebene steht auf 100%
    Die Funktion "Ebenen anzeigen" bringt auch nix...
    Inkscape aus und wieder einschalten bringt auch nix und den Computer runterfahren und neustarten auch nicht...
    WEnn ich das Bezier-bearbeiten Werkzeug (zweites von oben) benutze, erscheinen die Umrisse der Objekte ans farbige Linien, ansonsten nur die Auswahlboxen...

    Was ist da los?
  • Wie dick sind die Linien denn?
    Und die Anzeige->Ansichtsmodus->Umriss-Funktion zeigt alles an?

    Gruß
    Frank
  • DrachenbauerDrachenbauer März 2017
    Die Umriss-Funktion zeigt nix an

    Füllungen erscheinen auch nicht, wenn ich die Füllfarbe ändere

    Es hat während des zeichnens einer Kurve begonnen: überall da, wo das kästchen mit den Einrast-Infos am Cursor erschien, ließ es danach einen weißen "Abdruck" zurück.
    Als ich dann herausgezoomt habe, in der hofnunh, dass diese weißen Stellen verschwinden, war plötzlich alles unsichtbar
    Mit "alles auswählen" erscheinen Weiterhin die Auswahlrahmen der Objekte.
    Es sind insgesammt 19 Bezier-Kurven-Objekte mit je 4-6 Knoten.
  • Das ist merkwürdig.
    Kannst Du die Inkscape Datei irgendwo hochladen für uns?

    Gruß
    Frank
  • Was genau da schief läuft mit der Datei kann ich auf die Schnelle nicht sagen  aber alles auswählen und in ein neues leeres Dokument einfügen scheint zu funktionieren und im Browser konnte ich den Drachen auch sofort sehen:
    Vielleicht hilft das erstmal weiter.

    Gruß
    Frank
  • Moini März 2017
    Ich glaub, das hat irgendwas mit dem Spiro-Pfadeffekt zu tun. Den hat Frank evtl. nicht in seiner Version.

    Bei mir zeigt Inkscape 0.92.1 beim ersten Öffnen ein riesiges schwarzes Objekt auf der linken Seite an, das ein Pfad mit einem Spiro-Pfadeffekt ist (http://i.imgur.com/XtE9Cgv.png). Wenn ich das auswähle und dann den Pfadeffekt entferne, scheint sich die Datei ganz normal zu verhalten (wobei die Kreise dieselbe Farbe haben wie der Drachen, und daher nicht zu sehen sind, im Umrissmodus sind sie dann aber da).

    Ich konnte das Verschwinden allerdings auch reproduzieren, weiß nur nicht mehr genau, wie ich das angestellt habe.
  • DrachenbauerDrachenbauer März 2017
    ich habe den Spiro-effekt garnicht ausgewhlt.
    Ixh habe auch die runden Formen auf Normale Art und Weise erstellt.
  • Moini März 2017
    Der Spiro-Pfadeffekt ist nach einem Update von 0.91 auf 0.92(.1) beim Zeichnen mit dem Bleistift automatisch aktiviert, glaube ich. Vielleicht war das der Grund. Muss man dann manuell abschalten, leider... Er sollte auch nicht die ganze Zeichnung lahmlegen.
  • DrachenbauerDrachenbauer März 2017
    ich habe nicht mit dem Bleistift (Freihand-Werkzeug) sondern mit der Tinten-Feder (Bezier-Werkzeug) gezeichnet.
  • Kannst Du das Verhalten wiederholen?
    (Ich habe Dir eine bereinigte Version hochgeladen - gern geschehen)

    Gruß
    Frank
  • DrachenbauerDrachenbauer März 2017
    das kam ja wähernd ich so damit gearbeitet habe, wie ich es immer tue.
    und wo ist der link zur Bereinigten Version?
  • In meinem Beitrag vom 3.März.

    Gruß
    Frank
  • cape1011 Oktober 2018
    Hallo,

    ich habe ein Problem, das mir nunmehr schon zum zweiten Mal (das erste Mal bei einer anderen Datei) unter Inkscape 0.92 passiert ist:

    Und zwar habe ich eine ca. 5,6MB große SVG-Datei, die ich von Anfang an per Inkscape erstellt und seit jeher ohne Probleme damit bearbeitet habe. Nun habe ich eigentlich nichts ungewöhnliches gemacht, außer Punkte, Linien, Flächen (ohne nennenswerte Effekte oder dgl. - nur 3-4 Linien sind leicht unscharf; sehr wenige z.T. transparente Objekte) gezeichnet, bis ich ein Arbeitsergebnis aus der Datei als PNG-Datei exportieren wollte (was bislang sehr oft und problemlos funktionierte).

    Obwohl die Zeichnung eigentlich mindestens 4000 x 2000 Pixel bei 150dpi hat, wurden mir auf einmal 3 x 3 Pixel bei über 1500 dpi als Exportoption "vorgeschlagen", obwohl ich nichts in dem Bereich eingestellt habe. Nachdem mir das sehr skurril vorkam, schloss ich die Datei inkl. vorherigem Abspeichern, in der Hoffnung, dass ein Neustart die Sache erledigt.

    Nach dem Neustart der Datei waren aber alle Ebenen weg und gar keine Elemente im Zeichenfenster. Jetzt schiebe ich natürlich Panik, da ich das Dokument beruflich dringend brauche und nur eine zwei Tage alte Sicherungskopie der Datei als Backup habe. Tage der Arbeit umsonst, wenn ich die offenbar kaputte Datei (deren Dateigröße nach wie vor unverändert ist und im XML-Editor eine ganze menge Daten angezeigt werden) nochmal neu bearbeiten muss...

    Ich habe schon versucht:
    - Ansicht -> Anzeigemodus -> Umriss => Nichts passiert
    - Deckkraft auf 100% => Nichts passiert - wie auch, es sind ja keine Ebenen auswählbar

    Wie gesagt, alle Ebenen sind weg, keine Elemente im Zeichenfenster. Man kann auch nix unsichtbares auswählen.
    - Was könnte hier passiert sein - mit einer Datei, die vorher tadellos gelaufen ist?
    - Ist die Datei vielleicht zu groß für Inkscape?
    - Kann man die Datei (deren Volumen offenbar unverändert ist) noch irgendwie retten?

    Mit einem anderen Vektorgrafikprogramm zu testen habe ich leider keine Möglichkeit.
    Öffne ich die Problemdatei mit dem Windows-Internet-Explorer, zeigt zeigt sich nur eine weiße Fläche (bei der Backup-Datei wird im Internet Explorer bis auf die Schriftarten alles richtig angezeigt).

    Technische Daten:
    - Inkscape 0.92
    - Windows 10
    - Intel Core i5-4200U CPU @ 1.6 Ghz  2.3 GHz
    - 8GB RAM (7,88 verwendbar)
    - 64 Bit Betriebssystem mit 64 Bit Prozessor
    - NVIDIA GeForce GT 740M

    Da die Datei vertrauliche Daten enthält, würde ich es vorziehen, wenn sich erstmal jemand hier meldet, der sich das ganze mal ansehen will. Anschließend kann ich bei Bedarf einen Link zur Datei bzw. wenn möglich direkt per E-Mail schicken, damit sie nicht auf unbestimmte Zeit öffentlich zugänglich ist...

    Über Rückmeldungen wär' ich sehr dankbar.

    MfG
    cape1011

  • cape1011 Oktober 2018
    ...mir fällt noch ein:

    Kurz bevor ich die PNG-Datei erstellen wollte, habe ich zum Glück noch problemlos eine PDF-Datei mit einem Ausschnitt aus der SVG-Datei generieren können. Falls hilfreich, kann ich sie gern ebenfalls bereitstellen.

    MfG
    cape1011
  • Frank Beckmann Oktober 2018
    Moin.
    Wie groß ist denn die Datei jetzt?
    5,6MB für eine SVG ist ganz schön happig -es sei denn es befinden sich Eingebettete Bilder darin.

    Gruß
    Frank
  • Moini Oktober 2018
    Tipp: im Exportdialog, exportiere 'Seite', nicht 'Benutzerdefiniert'.
  • cape1011 Oktober 2018
    5,604050 MB. In einer Ebene sind Hintergrundkarten als Rastergrafik abgelegt.

    Ist wohl vermutlich etwas zu viel für Inkscape, was?

    Ich habe aber noch eine andere 6MB-Datei (ohne Rastergrafiken), bei der alles gut läuft...

    MfG
    cape1011
  • Moini Oktober 2018
    Und wie sieht's im XML-Dialog aus? Ist da irgendwas?
    Bearbeiten > XML-Editor
  • cape1011 Oktober 2018
    Im XML-Editor leider auch keine Spur mehr von den Ebenen. Aber ja, "Irgendwas" ist da schon...
    Mir fällt eben auf, dass ich oben "XML-Editor" geschrieben habe, aber eigentlich Wordpad meinte. Hups... :^o

    Erkenntnis: Abgesehen von der ungefähren Größe des Dokuments ist nix mehr so wie vorher.

    Ich versuche Bilder (130-180 KB) dazu anzuhängen (klappt grad irgendwie nicht).
  • cape1011 Oktober 2018

  • Frank Beckmann Oktober 2018
    Bilder hier ins Forum laden ist die Pest. Versuche bitte einen externen Hoster oder Dropbox oder was Du vielleicht sonst verwendest. Danke.

    Gruß
    Frank
  • cape1011 Oktober 2018
    "Bilder hier ins Forum laden ist die Pest."
    Bedauerlich. Aber danke für den Hinweis.

    Hier die Bilder:



    MfG
    cape1011
  • Moini Oktober 2018
    Wenn diese Datei tatsächlich 5 Mb groß ist, dann sind das Muster und Farbmuster, Gradienten und ähnliches, die in den defs gespeichert sind. Du kannst spaßeshalber mal 'Datei > Dokument säubern' machen, und gucken, wieviel danach noch übrig bleibt. Inhalte sehe ich im XML-Editor leider keine, und das Dokument sieht auch irgendwie kaputt aus, so als ob Inkscape während des Speicherns vorzeitig beendet worden wäre.
    Genaues könnte ich nur sagen, wenn ich die Datei selbst in den Händen hätte.

    Falls Du nicht die aktuellste Inkscape-Version verwendest (0.92.3), aktualisiere bitte auf diese. Es gab in älteren Versionen unter Windows das Problem, dass beim Schließen von Inkscape Dateioperationen abgebrochen wurden.

    Zusätzlich sieh zu, dass Du die automatischen Backups anschaltest (in den Einstellungen, unter Bearbeiten > Einstellungen > Eingabe/Ausgabe > Automatische Sicherung).
  • cape1011 Oktober 2018
    Servus Moini,

    danke für die Tipps. Werde gleich die aktuellste Version installieren und automatisches Speichern aktivieren (wenn ich das schon vorher bemerkt hätte :(( ). Anbei der Link zur Datei.


    Wenn sie schon nicht gerettet werden kann, dann soll sie wenigstens der Weiterentwicklung/Information dienen ;-)  Wär super, wenn du mir noch mitteilen könntest, was du ggf. rausgefunden hast. Vielleicht kann ich solche Ausfälle ja irgendwie vermeiden, wenn ich neben dem Autospeichern in Zukunft irgendwas beachte(?))...

    MfG
    cape1011
     
  • cape1011 Oktober 2018
    Geil. Problem gelöst. Ich habe zuvor mit 0.92.1. gearbeitet.
    Habe eben mit der aktuellen Version 0.92.3. die "defekte" Datei geöffnet.
    Alles wieder so wie vorher. 

    Man bin ich happy, dass ich nicht nochmal 5 Stunden nacharbeiten muss.
    Die Lösung kann so einfach sein. Danke!
    >:D<
  • Moini Oktober 2018
    Mh, na sowas :) Unerwartet - aber freut mich!

Hey Fremder!

Sieht so aus als wenn du neu hier bist. Wenn du mitmachen willst, drücke einen dieser Buttons!

In dieser Diskussion