Node-Typ bei Bezier-Linien
  • volki September 2017
    Ich bin von Inkscape bis 0.91 gewohnt, dass beim Zeichnen von Bezier-Linien die Nodes eckig (cusp) werden, wenn man nur klickt, und abgerundet (smooth), wenn man beim Klicken zieht. In 0.92 werden beim Klicken+Ziehen die Nodes scheinbar zufällig mal abgerundet, mal eckig - wobei auch die eckigen Nodes vorerst nicht eckig aussehen, weil die Anfasser in beiden Richtungen in der selben Geraden liegen. Die Auswirkung merkt man erst dann, wenn man einen Anfasser bewegt, denn dann bewegt sich der gegenläufige nicht mit und es kommt wirklich ein Knick in die Linie.

    Ist das ein Bug oder ein Feature, und wie lässt sich das bisherige, nachvollziehbare Verhalten wiederherstellen?
  • Frank Beckmann September 2017
    Moin.
    Ich kann das leider gar nicht nachvollziehen (macOS/Inkscape 0.92.2). Drückst Du vielleicht aus Versehen noch die Hochstelltaste manchmal?

    Gruß
    Frank 
  • volki September 2017
    @Frank: Nein. Probier mal, beim Zeichnen die Anfasser über kürzere Distanzen (wenige Pixels) zu ziehen. Mir kommt vor, dass der Fehler vor allem dann auftritt.

    @Moini: Danke für die Info. Wieso steht dort "This bug affects 1 person"? Bringt es was, sich dort zu registrieren um den Bug zususagen hochzuvoten?
  • Frank Beckmann September 2017
    Moin.
     Mmmh - Ich glaube das hat mehr mit der Auflösung der Maus zu tun. Ich musste nie einen Anfasser nur "wenige Pixel" bewegen.. Wenn ich im 1:1 Modus bin ist die kürzeste Distanz 4px (billige 800dpi-Maus) - nämlich die bis ich unter dem Knotenpunkt mit dem Cursor hervorgekrochen komme und ihn überhaupt wieder sehe. Aber so kann ich nicht arbeiten - ich würde immer formatfüllend reinzoomen. Ich habe meine Zweifel ob diese Arbeitsweise wirklich einen Bug zum Vorschein bringt. Es sei denn Du zeichnest bereits formatfüllend und hast dann diese unterschiedlichen zufälligen Nodes. Dann hast Du ein Problem, das ich aber dennoch nicht am Mac nachstellen kann.

    Gruß
    Frank
  • volki September 2017
    Du meinst Bildschirm-Pixels, ich meinte eher Dokument-Pixels. Aber egal. Der Fehler liegt sicher nicht an der Maus, denn wenn man so weit zieht, dass die Anfasser erscheinen, dann sollte unabhängig von der Maus oder deren Auflösung der Knoten rund werden. Außerdem verwende ich die selbe Maus und die selbe Arbeitsweise wie in 0.91, wo das Problem noch nicht bestand.
  • Frank Beckmann September 2017
    Ich kann Dir leider nicht weiter helfen.
  • Moini September 2017
    Das mit dem Hochvoten ist zumindest so gedacht. Wenn Du noch weitere Infos beisteuern kannst, freuen sich die Entwickler am meisten, denn das zuverlässige Reproduzieren macht es leichter, den Fehler zu beheben.
  • volki September 2017
    Ok, ich hab mich dort als zweiter betroffener User gemeldet und etwas dazugeschrieben, was die Reproduzierbarkeit hoffentlich verbessert.

Hey Fremder!

Sieht so aus als wenn du neu hier bist. Wenn du mitmachen willst, drücke einen dieser Buttons!

In dieser Diskussion