Ein Programm ohne deutsche Sprache
  • metaponto Januar 10
    Das Inkscape 0.92.2 (5c3e80d, 2017-08-06) habe ich installiert (windows-7, 64-bit).  Das Programm läuft, jedoch lässt sich die Sprache partout nicht auf deutsch umstellen.Iin der Datei preferences.xml ist die Zeile language="de" bereits richtig enthalten. In den erweiterten Systemeigenschaften habe ich eine neue Umgebungsvariable lang mit Wert de hinzugefügt. Auch der Aufruf über eine Batch-Datei ( .bat oder .cmd) bringt kein deutschsprachiges Ergebnis.
    Ein Löschen aller Sprachpakete außer dem deutschen hilft auch nicht weiter.
    Ich kann nicht nachvollziehen, daß InkScape auf einem Rechner in deutscher Sprache laufen soll.
  • Moini Januar 10
    Welches ist denn Deine Systemsprache?
    In Inkscape selbst hast Du unter Edit > Preferences > Interface die Sprache auf Deutsch eingestellt? Oder hast Du die Option da nicht?

    Hast Du denn bei der Installation auch die Sprachpakete alle mitinstalliert?

    Ich würde versuchen, Inkscape einmal komplett zu deinstallieren, und dann nochmal neu zu installieren, und dabei genau darauf zu achten, dass die richtige Sprache und die entsprechenden Pakete ausgewählt sind (ich glaube zumindest, dass es die Option gibt, ich verwende Linux und habe noch nie selbst Inkscape unter Windows installiert, nur den Installer übersetzt...).
  • metaponto Januar 10
    @ Moini
    Inkscape habe ich schon mehrmals installiert; auch eine portable Version (0.92.1) und jedes Mal die Sprache deutsch eingestellt. Aller Versuche am Programm (s.o.) und an meinem System schlugen bisher fehl.  :-(
  • Moini Januar 11
    Daraus entnehme ich, dass Du die Option im Einstellungsdialog hast. Stimmt das?

    Was ist denn nun Deine Betriebssystemsprache?
    Und welche Sprache verwendet Inkscape stattdessen?

    Hast Du irgendwo in Deiner Inkscape-Installation einen Ordner namens 'locale'? Sind in dem Ordner noch weitere Ordner? Gibt es da einen mit dem Namen 'de'?
    Ist in dem, in einem Unterordner LC_MESSAGES eine Datei namens 'inkscape.mo' drin?

    Was sagt Inkscape, wenn Du es mittels 'inkscape' oder 'inkscape.exe' auf der Kommandozeile startest?

    Wenn Deutsch Deine Systemsprache ist, was erhältst Du, wenn Du keine Sprache auswählst, also 'System'?
  • metaponto Januar 11
    @Moini
    Danke für deine Mühe.
    - im DropDown 'Edit' -> 'Preferences...'-> 'Interface' -> 'Windows' -> 'Languane' habe ich es mit 'System' und 'de' versucht, trotzdem - nach jedem Neustart des Programmes Sprache in englisch.
    - meine Betriebssystemsprache und das Gebietsschema sind deutsch
    - im Installationsordner inkscape\share\locale\LC_MESSAGES befindet sich unter den drei Dateien auch die Datei 'inkscape.mo', deren Einsicht mit einem Hex-Editor englischen und deutschen Text enthält.
    - auch der Start auf Dos-Ebene bringt nur das englische Ergebnis

    da dieses Problem bei der portablen Version (Inkscape 0.92.1 r15371) wie auch bei der installierten Version (Inkscape 0.92.2 (5c3e80d, 2017-08-06) besteht, scheint der Fehler vordergründig mit meinem System zusammenzuhängen
  • Moini Januar 11
    Das heißt, bei Dir gibt es keinen Ordner inkscape\share\locale\de\LC_MESSAGES ?

    So wie hier:
    http://i.imgur.com/wfKNmkO.png ?

    Falls Du das noch nicht so probiert hast:
    Deinstalliere Inkscape komplett, danach installiere es nochmal. Während der Installation wähle einfach mal alle Sprachen aus. Irgendwas könnte da schief gelaufen sein.
  • metaponto Januar 11
    Problem gelöst
    Danke noch einmal allen hier interessierten.
    Inkscape deinstalliert und neu installiert. Die frühere Installation hatte ich wegen Platzmangel nicht auf der Systemplatte 'c:' sondern auf einem anderen physikalischen Laufwerk vollzogen. Die Einstellungen von Inkscape wurden hierbei trotzdem auf C:\benutzer\...\appdata\roaming\inkscape\ .... gespeichert. Scheinbar ruft Inkscape die 'Preferences' nur aus einem Installationslaufwerk 'C:' auf. Ist ja weiter nicht schlimm.
    Bei der Neuinstallation auf 'C:' reichte schon die Einstellung -de- für den ersten Programmaufruf in deutscher Sprache.
  • Moini Januar 11
    Okay...

    Heißt das, es war es nötig, dass BEIDES (sowohl die Benutzerkonfiguration, also vor allem die preferences.xml, als auch das Inkscape-Programm selbst) auf C: liegt, damit es geht?

    Das würde ich für einen Bug halten...
  • metaponto Januar 12
    @ Muini
    Genauso sieht es aus. Die portable Version (0.92.1) habe ich nicht auf der Systemplatte und diese ist also nicht in deutsch verfügbar - gut, vom USB-stic habdas noch nicht probiert.
  • Moini Januar 12
    Könntest Du das nochmal schön übersichtlich als Fehlerbericht posten:
    https://bugs.launchpad.net/inkscape ?
  • Moini Januar 17
    Ich hab grad nochmal den Inkscape-Windows-Experten gefragt. Er meinte, ihm sei das Problem so nicht bekannt, es sei denn es wären im Pfad irgendwie entweder Umlaute und ähnliche Sonderzeichen oder 'bin' oder 'lib' enthalten.
    Für die portable Version hatte er spontan erstmal keine Idee.

    War da irgendwas mit Umlauten, bin oder lib bei Dir?
  • metaponto Januar 21
    Nein, Umlaute für Ordnernamen, Leerzeichen oder ähnliches verwende ich grundsätzlich nicht und bin oder lib habe ich auch nicht verwendet
  • Moini Januar 21
    Dann wäre ein Fehlerbericht echt toll :)

Hey Fremder!

Sieht so aus als wenn du neu hier bist. Wenn du mitmachen willst, drücke einen dieser Buttons!

In dieser Diskussion