Einheiten lassen sich nicht von 'px' auf 'mm' umstellen
  • Hallo, ich habe eine alte Datei, welche 'px' für 'Units' und 'Display Units' eingestellt hatte. Nun wären mir 'mm' aber lieber. Leider springen die 'Display Units' immer wieder auf 'px' retour, die Größe und Position von Objekten wird mir demnach in 'px' angezeigt. Lässt sich dieses Verhalten irgendwie ändern? Danke!
  • Hier wird wohl über das gleiche Problem diskutiert:


    Ich sehe mir dass dan morgen in Ruhe an. Gute Nacht!
  • Moini März 10
    Einfache Lösung:

    Ändere kurz den Wert von 'Skalierung x'  (Dokumenteneigenschaften: Reiter 'Seite') und ändere ihn nach dem Drücken von Enter wieder zurück.
  • Die Einheiten werden damit zwar auf 'mm' umgestellt, nach dem neuerlichen Öffnen der Datei steht unter Skalierung aber "3,77953". Wenn ich den Wert auf "1" zurücksetze wird meine Illustration vergrößert. Außerdem reagiert meine Illustration nun beinahe nicht mehr wenn ich sie mit der Maus verschieben will.

    Edit: Das Problem mit dem Verschieben hängt wohl doch mit der Einstellung "Snap to path intersections" zusammen. Sobald das Icon aktiviert ist, lässt sich mein Objekt (Gruppe aus 180 Objekten) nur mehr verzögert mit der Maus verschieben.

    Edit 2: Das beim Ändern der 'Display units' der Wert unter 'Scale' von 1 (mm) zu 0,26458 (px) umspringt ist normal, oder?
  • Ich habe leider ein weiteres Problem, dass mit diesem Problem wohl zusammenhängt. Nach der getricksten Umstellung von 'px' auf 'mm', hat meine selbsterstellte Vorlage für einen Stiftstil ("Shape from clipboard" für "Draw bezier curves and straight lines") nicht mehr die richtige Größe. Damit erstellte Bezierkurven und Linien werden deutlich dünner als die ursprünglich erstellten Pfade. Das ist für mich ein echtes Problem, da ich bei vielen Illustrationen die Option "Shape from Clipboard" verwendet habe. Den selben Fehler habe ich auch, wenn ich meine Illustrationen in eine neu geöffnete Inkscap Datei kopiere. In der alten Datei (mit 'px' als 'Units') sind die Größen für mit der Option "Shape from clipboard" erstellte Pfade korrekt, in der neuen Datei passt's dann nicht mehr :/

    Das beschriebene Verhalten bezieht sich auf Inkscape 0.92.4. Unter 1.0beta1 verhält sich "Shape from clipboard" wieder gänzlich anders. Der gezeichnete Pfad ist größer als zuvor und besteht immer aus einer "Stroke" ohne "Fill". Wenn ich "Stroke" abwähle und "Fill" anwähle passt die Breite des Pfades beinahe annähend mit den originalen Pfaden überein.
  • Moini März 11
    Tritt die Änderung der Stiftstärke mit dem auf 1 gesetzten Scale-Wert auf, oder mit dem, den Inkscape automatisch setzt?

    (bitte nicht manuell ändern, außer temporär für die Behebung des ersten Problems bzw. wenn Du weißt was Du tust.)
  • Hallo, ich habe mittlerweile herausgefunden, dass sich die Stärke unter "Pfad/Pfadeffekte ..." einstellen lässte. Den 'px' auf 'mm' Bug finde ich trotzdem sehr ärgerlich. Schade, dass dieser nie behoben wurde.
  • Moini März 23
    Ist doch schon behoben ... Warte halt auf die nächste Version, oder installiere Dir eine Betaversion (eine aktuelle, nicht den Stand, den es auf der Webseite als Beta2 zum Herunterladen gibt).
  • Ich hatte vor einigen Tagen das aktuelle AppImage probiert und da hatte es noch nicht ohne Probleme mit der Skalierung geklappt. Muss mir das beizeiten nochmal ansehen.
  • Moini März 23
    Kopier dann mal die vollständige Versionsnummer von Hilfe > Über hierher, damit wir vergleichen können.

    Neueste Versionen findest Du unter
    https://gitlab.com/inkscape/inkscape/tree/1.0.x/ : Download-Button ziemlich weit oben rechts : linux:appimage

    Manchmal gibt das einen 404-Fehler (Seite nicht gefunden), dann müsstest Du unter
    https://gitlab.com/inkscape/inkscape/pipelines
    nach der neuesten Zeile mit dem Status 'passed' für den Zweig '1.0.x' suchen, und dort den Download-Knopf drücken.

Hey Fremder!

Sieht so aus als wenn du neu hier bist. Wenn du mitmachen willst, drücke einen dieser Buttons!

In dieser Diskussion