zeichentablett und linux
  • apblnapbln März 2007
    hallo benutzer,
    habe vor einiger zeit mit linux (xubuntu 6.10) angefangen und wollte eigentlich auch mein zeichentablett (wacom graphire 4) benutzen.
    leider funktioniert es nur im mausmodus, welcher mir aber wenig nützt. direkt im ubuntu-forum wusste keiner rat, das
    "The Linux Wacom Project" kenne ich und der link http://www.linux-user.de/ausgabe/2006/01/091-tablets/index.html verstehe ich nur zu 50%
    gibts denn keine einfache lösung.. vielleicht hat ja schon jemand seine erfahrung damit gemacht.
    grüße sebastian
  • tobiastobias März 2007
    Die beste Hilfe bekommt du wahrscheinlich unter gimpforum.de. Da wurde schon mehrfach Leuten mit Wacoms weiter geholfen. Benutz da am besten mal die Suche.
  • alnilamalnilam März 2007
    Hallo Sebastian,

    Ich benutze mein Wacom Graphire 4 auch unter Ubuntu (Edgy Eft). Es hat seit dem Upgrade auf Edgy problemlos funktioniert, da da scheinbar die nötigen Treiber und so schon dabei sind.

    Ich vermute, dass in deiner xorg.conf (unter /etc/x11/) noch etwas falsch eingetragen ist. Jedem Eingabegerät (Maus, Tastatur, Stift) ist ja ein "event" zugeordnet. Die findest du alle in dev/input/. Die Zuordnung von diesen Events zum Gerät geschieht in der xorg.conf. Bei mir hat anfangs das Tablett noch mit in das Event "mice" hineingewirkt. Darum hat es nur im Maus-Modus funktioniert. Leider kenne ich mich damit auch nicht sehr gut aus. Vielleicht hilft es Dir ja schon, in dieser Richtung ein wenig weiter zu suchen.

    Wenn es Dir hilft, kann ich auch mal meine xorg.conf posten.

    grüße, alnilam
  • apblnapbln März 2007
    @tobias.. ja danke von der seite habe ich ja den link zu linux-user.

    @alnilam ja danke, na diese dateien werde ich mir mal anschauen. mal sehen was ich dort eintragen oder ändern kann. gerne kannst du die datei mal posten, so habe ich was zum vergleich.
  • daswaldhorndaswaldhorn März 2007
    Hallo,

    für das Bearbeiten der xorg.conf ist vielleicht diese Anleitung hilfreich.

    Grüße, Carsten
  • alnilamalnilam März 2007
    Hallo Sebastian,

    Entschuldige die späte Antwort. Hier noch ein Ausschnitt aus meiner xorg.conf, der die Einstellungen der Input Devices zeigt. Vielleicht hilft es Dir ja.

     
    Section \"InputDevice\"
    Identifier \"Generic Keyboard\"
    Driver \"kbd\"
    Option \"CoreKeyboard\"
    Option \"XkbRules\" \"xorg\"
    Option \"XkbModel\" \"pc105\"
    Option \"XkbLayout\" \"de\"
    Option \"XkbVariant\" \"nodeadkeys\"
    EndSection

    Section \"InputDevice\"
    Identifier \"Configured Mouse\"
    Driver \"mouse\"
    Option \"CorePointer\"
    Option \"Device\" \"/dev/input/mice\"
    Option \"Protocol\" \"ExplorerPS/2\"
    Option \"ZAxisMapping\" \"4 5\"
    EndSection

    Section \"InputDevice\"
    Driver \"wacom\"
    Identifier \"stylus\"
    Option \"Device\" \"/dev/input/wacom\" # Change to
    # /dev/input/event
    # for USB
    Option \"Type\" \"stylus\"
    Option \"ForceDevice\" \"ISDV4\" # Tablet PC ONLY
    EndSection

    Section \"InputDevice\"
    Driver \"wacom\"
    Identifier \"eraser\"
    Option \"Device\" \"/dev/input/wacom\" # Change to
    # /dev/input/event
    # for USB
    Option \"Type\" \"eraser\"
    Option \"ForceDevice\" \"ISDV4\" # Tablet PC ONLY
    EndSection

    Section \"InputDevice\"
    Driver \"wacom\"
    Identifier \"cursor\"
    Option \"Device\" \"/dev/input/wacom\" # Change to
    # /dev/input/event
    # for USB
    Option \"Type\" \"cursor\"
    Option \"ForceDevice\" \"ISDV4\" # Tablet PC ONLY
    EndSection

  • apblnapbln März 2007
    es ist nie zu spät ;)

    bin gerade mit dem ubunturechne online: meine xorg.conf sieht deiner verdammt ähnlich. also ist wohl alles
    richtig eingetragen!

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type \"man /etc/X11/xorg.conf\" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section \"Files\"
    FontPath \"/usr/share/X11/fonts/misc\"
    FontPath \"/usr/share/X11/fonts/cyrillic\"
    FontPath \"/usr/share/X11/fonts/100dpi/:unscaled\"
    FontPath \"/usr/share/X11/fonts/75dpi/:unscaled\"
    FontPath \"/usr/share/X11/fonts/Type1\"
    FontPath \"/usr/share/X11/fonts/100dpi\"
    FontPath \"/usr/share/X11/fonts/75dpi\"
    FontPath \"/usr/share/fonts/X11/misc\"
    # path to defoma fonts
    FontPath \"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType\"
    EndSection

    Section \"Module\"
    Load \"i2c\"
    Load \"bitmap\"
    Load \"ddc\"
    Load \"dri\"
    Load \"extmod\"
    Load \"freetype\"
    Load \"glx\"
    Load \"int10\"
    Load \"type1\"
    Load \"vbe\"
    EndSection

    Section \"InputDevice\"
    Identifier \"Generic Keyboard\"
    Driver \"kbd\"
    Option \"CoreKeyboard\"
    Option \"XkbRules\" \"xorg\"
    Option \"XkbModel\" \"pc105\"
    Option \"XkbLayout\" \"de\"
    Option \"XkbOptions\" \"lv3:ralt_switch\"
    EndSection

    Section \"InputDevice\"
    Identifier \"Configured Mouse\"
    Driver \"mouse\"
    Option \"CorePointer\"
    Option \"Device\" \"/dev/input/mice\"
    Option \"Protocol\" \"ExplorerPS/2\"
    Option \"ZAxisMapping\" \"4 5\"
    Option \"Emulate3Buttons\" \"true\"
    EndSection

    Section \"InputDevice\"
    Driver \"wacom\"
    Identifier \"stylus\"
    Option \"Device\" \"/dev/wacom\" # Change to
    # /dev/input/event
    # for USB
    Option \"Type\" \"stylus\"
    Option \"ForceDevice\" \"ISDV4\" # Tablet PC ONLY
    EndSection

    Section \"InputDevice\"
    Driver \"wacom\"
    Identifier \"eraser\"
    Option \"Device\" \"/dev/wacom\" # Change to
    # /dev/input/event
    # for USB
    Option \"Type\" \"eraser\"
    Option \"ForceDevice\" \"ISDV4\" # Tablet PC ONLY
    EndSection

    Section \"InputDevice\"
    Driver \"wacom\"
    Identifier \"cursor\"
    Option \"Device\" \"/dev/wacom\" # Change to
    # /dev/input/event
    # for USB
    Option \"Type\" \"cursor\"
    Option \"ForceDevice\" \"ISDV4\" # Tablet PC ONLY
    EndSection

    Section \"Device\"
    Identifier \"NVIDIA Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR]\"
    Driver \"nv\"
    BusID \"PCI:1:0:0\"
    EndSection

    Section \"Monitor\"
    Identifier \"miro P1998F\"
    Option \"DPMS\"
    EndSection

    Section \"Screen\"
    Identifier \"Default Screen\"
    Device \"NVIDIA Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR]\"
    Monitor \"miro P1998F\"
    DefaultDepth 24
    SubSection \"Display\"
    Depth 1
    Modes \"1280x1024\" \"1024x768\" \"800x600\" \"640x480\"
    EndSubSection
    SubSection \"Display\"
    Depth 4
    Modes \"1280x1024\" \"1024x768\" \"800x600\" \"640x480\"
    EndSubSection
    SubSection \"Display\"
    Depth 8
    Modes \"1280x1024\" \"1024x768\" \"800x600\" \"640x480\"
    EndSubSection
    SubSection \"Display\"
    Depth 15
    Modes \"1280x1024\" \"1024x768\" \"800x600\" \"640x480\"
    EndSubSection
    SubSection \"Display\"
    Depth 16
    Modes \"1280x1024\" \"1024x768\" \"800x600\" \"640x480\"
    EndSubSection
    SubSection \"Display\"
    Depth 24
    Modes \"1280x1024\" \"1024x768\" \"800x600\" \"640x480\"
    EndSubSection
    EndSection

    Section \"ServerLayout\"
    Identifier \"Default Layout\"
    Screen \"Default Screen\"
    InputDevice \"Generic Keyboard\"
    InputDevice \"Configured Mouse\"
    InputDevice \"stylus\" \"SendCoreEvents\"
    InputDevice \"cursor\" \"SendCoreEvents\"
    InputDevice \"eraser\" \"SendCoreEvents\"
    EndSection

    Section \"DRI\"
    Mode 0666
    EndSection

Hey Fremder!

Sieht so aus als wenn du neu hier bist. Wenn du mitmachen willst, drücke einen dieser Buttons!

In dieser Diskussion