Font wird nicht erkannt
  • ill66ill66 Dezember 2005
    sehr komsich:
    hier auffm laptop (winXP) hab ich ein paar extra-schriftarten installiert (TrueType), für ne drucksache, die ich in inkscape gemacht hab.

    aus irgendeinem grund erkennt er EINE davon aber nicht (sprich in inkscape wird der text in standard-schiftart gezeigt) --die andern gehen alle und die fragliche hier funktioniert auf anderen rechnern (ob win oder linux) auch normal.

    hat jemand ne idee? hab die natürlich schon zigmal gelöscht und wieder installiert, ohne erfolg.
    in demnamen kommt einausrufezeichen vor (yikes!) --könnte es da dran liegen?
  • fZapfZap Dezember 2005
    Mit dem Font stimmt auch etwas nicht. Ich habe unter linux die Schriftart unter /usr/share/fonts/* kopiert. Wird unter Inkscape erkannt, auch im Preview, aber mehr nicht. Jedes mal wenn man es einstellt springt er auf den Standard Font um.

    Unter Windows unter $windir/fonts geht es auch nicht. Wird nicht erkannt, auch nicht von M$-Standard-Office Anwendungen, nicht nach Neustart oder Umbenennung des Fonts.
  • ill66ill66 Dezember 2005
    hm, yikes! meinst du? auf meinem linux-rechner und den winXP-rechner auf der arbeit klappt das überall ohne probleme...
  • ill66ill66 April 2006
    mist --anscheinend passiert das nicht nur, wenn der dateiname ein sonderzeichen enthält sondern auch der font-titel!
    hab hier "Alfredo's Dance" und obwohl die TTF nur einfach ALFREDO heißt, macht innkscape da die gleichen mucken wie bei yikes!, was ich auf das apostroph zurückführe....

    gibt es denn da keine lösung? wenns nur der dateiname wäre, könnte man den ja ändern --aber kommt man irgendwie an die meta-angaben ran?
  • forestgreenforestgreen April 2006
    Vielleicht kann man das Sonderzeichen mit einem Hex-Editor in der Font-Datei lokalisieren und durch ein "harmloses" Zeichen ersetzen.
    Für sowas benutze ich gerne XVI32.
    Wenn du willst, schick mal die Datei und ich probier das mal aus.
    Grüße
    Schnappi60
  • fZapfZap April 2006
    Ja das mit der Fonterkennung ist teilweise recht nervig, ich kann mir auch nicht erklären warum manche Fonts (zB Yikes!) streiken. Yikes! habe ich schon damals mit einem Hexeditor bearbeitet den "Header" abgeschnitten, umbenannt und "durch den Fleischwolf" gedreht- es hat alles nicht gefruchtet. Ich sehe noch eine Möglichkeit den Font in den Fontforge zu bearbeiten und dann in eine Postscript oder Opentype-Schriftart zu wandeln. Vielleicht hilft es, wenn auch sehr aufwendig
  • ill66ill66 April 2006
    alfredo's dance lässt sich hier runterladen (shareware)
  • ill66ill66 April 2006
    na großartig --selbst wenn der font(name) nur zahlen enthält, gehts schon nicht mehr x____X
  • pasqpasq April 2006
    hi, ich ich weiss der thread ist alt, aber das passt hier rein glaub ich:

    ich bin von fedora auf ubuntu umgesattelt,
    alles top,
    nur erkennt inkscape "GARKEINE" font mehr :( ausser der stndardfont halt...
    ..hat einer ne lösung für mich?


    ciao pasq
  • fZapfZap Juni 2006
    Ich pack es mal in diesen thread hier.

    Ich habe seit der 0.44er Version wieder das leidige Font-Problem, dass ich unter WindowsXP/2000 nicht alle Schriftenarten zur Verfügung habe.

    Auf dem Rechner läuft zusätzlich noch die 0.43er Version und dort sind alle Schrifarten vorhanden. Wenn ich nur wüsste zum Henker woran das liegt

    unter Linux existiert das Problem nicht.
  • ill66ill66 Juni 2006
    zu mienem verdruss muss ich feststellen, dass die verwendung von fonts, die sonderzeichen oder zahlen im namen haben nach wie vor nicht geht *grmbl*
  • fZapfZap Juni 2006
    Die in der FAQ beschriebene Lösung auf wiki.inkscpae.org, über "Löschen der .fonts.cache-1 in $HOME":http://wiki.inkscape.org/wiki/index.php/DeFAQ#Ich_habe_eine_neue_Schriftart_auf_meinem_Windows-System_installiert.2C_aber_in_Inkscape_erscheint_sie_nicht. (C:\Dokumente und Einstellungen\%USERNAME%) bringt keine Besserung.
  • fZapfZap März 2007
    Das leidige Problem mit fonts unter Windows.

    *Wie konnte ich das nur übersehen, dass das Problem ein Rechteproblem ist?*

    Ich hatte die Fonts unter Windows als _regulärer Benutzer mit eingeschränkten Rechten_ in das Verzeiczhnis


    C:\Windows\fonts


    kopiert, was auch anstandslos klappte, trotzdem wurden die fonts unter Inkscape nicht angezeigt. Nun das gleiche Spiel als Admin, dann als wieder als regulärer Nutzer angemeldet und alles da. :-) Scheinbar kann man unter Windows zwar Schriftarten in das Fontverzeichnis kopieren, aber dann werden sie vom System nicht erkannt. Deswegen bei der Schriftinstallation darauf achten, dass man es als Admin angemeldt ist. Die Schriftarten in das Homeverzeichnis zu installieren, also nach %APPDATA%\Inkscape funktioniert bei mir nur unter Linux.

Hey Fremder!

Sieht so aus als wenn du neu hier bist. Wenn du mitmachen willst, drücke einen dieser Buttons!

In dieser Diskussion